Jump to content

Surly forum brings my PC to its knees


Recommended Posts

For some time, I've had an issue when I try to browse the Surly forums: it just crushes my PC, locking up my browser (current version of Chrome) and any other applications that are running. Everything stops responding and just becomes slow as molasses, and I get heavy disk access for no apparent reason. It seems to be maxing out my system memory. If I wait long enough (a minute or three) things slowly come back and become usable again, but still sluggish. This forum is the only website that I regularly have this problem with, including several other forums or bulletin boards that run very smoothly. What on earth is Surly doing to my PC? Virus and malware scans don't turn up anything. The only Chrome extension I have is ABP. System info: quad core i7 860 (2.8+ ghz), 4 gig RAM, Windows 7, plenty of free hard drive space). (Yeah, it's old, but not so old that web surfing should be a strain.)

Thanks for any ideas.

 

 

 

Edited by Paper_jam
Link to post
Share on other sites
Just now, Paper_jam said:

For some time, I've had an issue when I try to browse the Surly forums: it just crushes my PC, locking up my browser (current version of Chrome) and any other applications that are running. Everything stops responding and just becomes slow as molasses, and I get heavy disk access for no apparent reason. It seems to be maxing out my system memory. If I wait long enough (a minute or three) things slowly come back and become usable again, but still sluggish. This forum is the only website that I regularly have this problem with, including several other forums or bulletin boards that run very smoothly. What on earth is Surly doing to my PC? Virus and malware scans don't turn up anything. The only Chrome extension I have is ABP. System info: quad core i7 860 (2.8+ ghz), 4 gig RAM, Windows 7. (Yeah, it's old, but not so old that web surfing should be a strain.)

Thanks for any ideas.

 

 

 

I'd say 4GB RAM plus W10 plus Chrome might be a problem.  But W7, so  . . .  I don't know.

Have you tried it in Firefox or Opera?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...