Jump to content
TXLNGHRN10

Weber 310 Propane $300 OBO

Recommended Posts

How much for just one knob?  I over twisted one the other day.

I've had my Weber Genesis for 10+ years and it's great - except for that damn knob.

Share this post


Link to post
Share on other sites
How much for just one knob?  I over twisted one the other day.
I've had my Weber Genesis for 10+ years and it's great - except for that damn knob.


Call em and I wouldn’t be shocked if they send one for free. Did that with the propane regulator(?), screwed it too tight and it cracked. Sent me a new one at no charge when I called them.

Share this post


Link to post
Share on other sites
On 12/3/2019 at 3:33 PM, Jerry Callo said:

How much for just one knob?  I over twisted one the other day.

I've had my Weber Genesis for 10+ years and it's great - except for that damn knob.

3 for $21

Share this post


Link to post
Share on other sites
On 12/3/2019 at 3:33 PM, Jerry Callo said:

How much for just one knob?  I over twisted one the other day.

I've had my Weber Genesis for 10+ years and it's great - except for that damn knob.

If you’re serious, I just decommissioned an old one that you can have all the knobs/parts off.

Share this post


Link to post
Share on other sites
1 hour ago, VolenteHawk said:

If you’re serious, I just decommissioned an old one that you can have all the knobs/parts off.

what model is yours?  i have the old (2008 with side controls) e-310, i might need a new ignition.  it sparks really slowly.  there's a little corrosion in the battery contacts but i think there might also be gunk buildup at the actual contact point where it sparks.  

Share this post


Link to post
Share on other sites
6 minutes ago, gsoda3 said:

what model is yours?  i have the old (2008 with side controls) e-310, i might need a new ignition.  it sparks really slowly.  there's a little corrosion in the battery contacts but i think there might also be gunk buildup at the actual contact point where it sparks.  

It was the E-310 (Spirit) with the front controls from ~10 years ago.  The bottom rusted/separated but otherwise everything worked when I replaced it.

It's just sitting around waiting for me to junk it at this point.

 

Share this post


Link to post
Share on other sites
37 minutes ago, VolenteHawk said:

It was the E-310 (Spirit) with the front controls from ~10 years ago.  The bottom rusted/separated but otherwise everything worked when I replaced it.

It's just sitting around waiting for me to junk it at this point.

 

i've got a genesis but they should have the same ignition system.  i'll see if i have time this weekend to try and clean my contacts, get a better idea if i need to replace the module or if they're just dirty.  i'll let you know what i find out. thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


mpu


Football ... Basketball ... Baseball ... Other Sports ... Recruiting ... Gambling ... Movies & TV ... Music ... Hobbies ... Lulz ... Food & Travel ... Daily Texan ... Help ... For Sale ... Politics ... Board Discussion
×
×
  • Create New...